Wednesday, October 31, 2012

VLAN Trunk Between Cisco and HP Procurve switch

With a small example we are going to see how we can use Cisco and HP switches together for Vlan trunking. Before we going to discuss that in detail, let me describe the difference in 'terms' using both in Cisco and HP.

Description                                                                   Cisco                    ProCurve
A port that belongs to a unique VLAN                               Access mode        Untagged
A port carries multiple VLANs using 802.1q tags               Trunk mode           Tagged

Now we can go with our example, here we are going to create two VLANs, VLAN 100 (Data) and VLAN 200 (Voice) and make use of these vlans on both Cisco and HP switches.

In our example we are going to use the 48th port on both HP and Cisco as the trunk ports and interconnects togther on these ports.

 On Procurve Switch:
     Go to configuration mode and enter the following commands,

Procurve-2510(config)#vlan 100
Procurve-2510(config)#name "Data"
Procurve-2510(config)#tagged 48

Procurve-2510(config)#vlan 200

Procurve-2510(config)#name "Voice"
Procurve-2510(config)#tagged 48

You can see the configuration as
Procurve-2510(config)#sh run
vlan 100
   name "Data"
   tagged 48
   exit

vlan 200

   name "Voice"
   tagged 48
   exit

On Cisco Switch:

    Go to configuration mode and enter the following commands,
Cisco-3560G>en
Password:
Cisco-3560G#conf t
Cisco-3560G(config)#vlan 100
Cisco-3560G(config-vlan)#name "Data"

Cisco-3560G(config-vlan)#vlan 200

Cisco-3560G(config-vlan)#name "Voice"

Cisco-3560G(config-vlan)#exit

Cisco-3560G(config)#interface g0/48
Cisco-3560G(config-if)#description "Uplink to Procurve switch"
Cisco-3560G(config-if)#switchport trunk encapsulation dot1q
Cisco-3560G(config-if)#switchport trunk allowed vlan 100,200
Cisco-3560G(config-if)#switchport mode trunk

show run on enable mode will list all the configuration and the switch port configuration will be like as follows,

interface GigabitEthernet0/48
description "Uplink to Procurve switch"
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-200
switchport mode trunk


Thats all for inter operating Cisco and Procurve switches :)


Desclaimer: Here I haven't mention about adding access port in a Vlan or otherwise making an access port other than trunk port.



5 comments:

  1. what about for HP configuration
    for trunk “Downlink to Cisco Switch” . Thanks

    ReplyDelete
    Replies
    1. That is already mentioned first. "tagged 48" means we have made port number 48 as a trunk port for specified vlans (here vlan 100 and vlan 200)

      Delete
    2. Thanks. coz i am newbie for HP. :)

      Delete
  2. I have to search sites with relevant information on given topic and provide them to teacher our opinion and the article. Immobilienmakler Dresden

    ReplyDelete